glibcのupdateは難しい

Linuxのコアライブラリだからそもそも難易度高いっすよね。

でも人間山が高いから上りたくなるもの。

そんなわけでyum でパッケージ入れられなくて困って、glibcを2.12から2.15に上げようとしたときの作業メモ


ref: https://unix.stackexchange.com/questions/176489/how-to-update-glibc-to-2-14-in-centos-6-5

% sudo ../configure —prefix=/opt/glibc-2.15
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking for gcc... no
checking for cc... no
checking for cl.exe... no
configure: error: in `/glibc_install/glibc-2.15/build':
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details

 

 

必要ライブラリを入れる
ref: https://stackoverflow.com/questions/41602742/linux-centos-upgrade-glibc-2-12-to-2-14-config-error

sudo yum -y install gcc automake autoconf binutils glibc-headers

 

 

手順続き

% sudo ../configure --prefix=/opt/glibc-2.15
% sudo make -j4
# -jオプションを付けるとmakeの速度が向上する
# make -j ${コア数 x 2} from http://d.hatena.ne.jp/rx7/20070927/p1

%
sudo make install


インストール完了したら新しいverを使うように指定(現在のセッションのみ)&シンボリックリンク張る

LD_LIBRARY_PATH=/opt/glibc-2.14/lib

export LD_LIBRARY_PATH

ln -sf /opt/glibc-2.15/glibc-2.15.so /lib/libc.so.6

 

 

再度、yum インストールを試すが、、、

Error: Package: php72-runtime-2.0-1.el7.remi.x86_64 (remi-safe)
Requires: scl-utils
Error: Package: php72-php-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: httpd-mmn = 20120211x8664
Available: httpd-2.2.22-1.23.amzn1.x86_64 (al-main)
httpd-mmn = 20051115
Available: httpd-2.2.27-0.12.4.amzn1.x86_64 (al-updates)
httpd-mmn = 20051115
Available: httpd-2.2.31-1.6.al12.x86_64 (al-updates)
httpd-mmn = 20051115
Available: httpd-2.2.31-1.8.al12.x86_64 (al-updates)
httpd-mmn = 20051115
Available: httpd-2.2.32-1.9.al12.x86_64 (al-updates)
httpd-mmn = 20051115
Installing: httpd-2.2.34-1.10.al12.x86_64 (al-updates)
httpd-mmn = 20051115
Error: Package: libraqm-0.7.0-4.el7.x86_64 (epel)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php72-php-mbstring-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php72-php-pdo-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: libzip5-1.7.1-1.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php72-php-xml-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libxml2.so.2(LIBXML2_2.9.0)(64bit)
Error: Package: php72-php-xml-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php72-php-json-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: fribidi-1.0.2-0.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
Requires: libtiff.so.5(LIBTIFF_4.0)(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
Requires: libpng15.so.15()(64bit)
Error: Package: php72-php-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
Requires: libpng15.so.15(PNG15_0)(64bit)
Error: Package: php72-php-pecl-mysql-1.0.0-0.17.20160812git230a828.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-mysqlnd-7.2.31-2.el7.remi.x86_64 (remi-php72)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: libzip5-1.7.1-1.el7.remi.x86_64 (remi-safe)
Requires: liblzma.so.5()(64bit)
Error: Package: libraqm-0.7.0-4.el7.x86_64 (epel)
Requires: libharfbuzz.so.0()(64bit)
Error: Package: php-pdo-7.2.31-2.el7.remi.x86_64 (remi-php72)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php72-php-common-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php72-php-cli-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: environment-modules-3.2.10-0.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php72-php-pecl-zip-1.19.0-1.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-common-7.2.31-2.el7.remi.x86_64 (remi-php72)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: php72-php-mysqlnd-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.15)(64bit)
Error: Package: libargon2-20161029-3.el7.x86_64 (epel)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php-json-7.2.31-2.el7.remi.x86_64 (remi-php72)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: gd-last-2.3.0-1.el7.remi.x86_64 (remi-safe)
Requires: libtiff.so.5()(64bit)
Error: Package: libzip5-1.7.1-1.el7.remi.x86_64 (remi-safe)
Requires: liblzma.so.5(XZ_5.0)(64bit)
Error: Package: libwebp7-1.0.3-1.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
Error: Package: php72-php-gd-7.2.31-2.el7.remi.x86_64 (remi-safe)
Requires: libpng15.so.15()(64bit)
Error: Package: oniguruma5php-6.9.5+rev1-2.el7.remi.x86_64 (remi-safe)
Requires: libc.so.6(GLIBC_2.14)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

 

 

解決せず。

glibcの新しいverは入っているが、たぶん、それを利用してyum installする方法が必要。